image




New York State Search




Klondike Solitaire

Java Klondike requires a java-enabled browser - I could not play these games on IE 6.0. However when I installed Netscape 7.0 I could play them in both browsers.



image
image
image